Back to overview
Degraded
Repeated Execution for Flows with Delay
Mar 19, 2026 at 2:00pm UTC
Affected services
Worker health
Resolved
Mar 19, 2026 at 6:00pm UTC
Resolved. The infinite loop bug has been fixed and Redis load is back to normal. All affected executions were replayed with no data loss.
Affected services
Created
Mar 19, 2026 at 2:00pm UTC
Flows with delay steps experienced repeated executions due to a bug causing infinite loops, overloading Redis. All affected executions were replayed after restoration with no data loss.
Affected services